En resumen
- CVE-2026-34052 es una vulnerabilidad MEDIO (CVSS 5.9) que afecta a jupyterhub-ltiauthenticator, lti jupyterhub authenticator (jupyter).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.34%, mayor que el 27.7% de las vulnerabilidades.
- Solución: actualizar a 1.6.3 o posterior.
Description
Summary
The LTI 1.1 validator stores OAuth nonces in a class-level dictionary that grows without bounds. Nonces are added before signature validation, so an attacker with knowledge of a valid consumer key can send repeated requests with unique nonces to gradually exhaust server memory, causing a denial of service.
Patches
- upgrade jupyterhub-litauthenticator to 1.6.3
NVD description
LTI JupyterHub Authenticator is a JupyterHub authenticator for LTI. Prior to version 1.6.3, the LTI 1.1 validator stores OAuth nonces in a class-level dictionary that grows without bounds. Nonces are added before signature validation, so an attacker with knowledge of a valid consumer key can send repeated requests with unique nonces to gradually exhaust server memory, causing a denial of service. This issue has been patched in version 1.6.3.
Más vulnerabilidades de jupyterhub-ltiauthenticator
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free