En resumen
- CVE-2026-34215 es una vulnerabilidad MEDIO (CVSS 6.5) que afecta a parse-server (parseplatform), parse-server.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.31%, mayor que el 24.4% de las vulnerabilidades.
- Solución: actualizar a 9.7.0, 8.6.63, 9.7.0-alpha.7 o posterior.
| Package | Affected versions | Patched versions |
|---|
| parse-server | = 9.7.0≥ 9.0.0, < 9.7.0< 8.6.63
| 9.7.08.6.63
|
| parse-server npm | ≥ 9.0.0, < 9.7.0-alpha.7< 8.6.63
| 9.7.0-alpha.78.6.63
|
Description
Impact
The verify password endpoint returns unsanitized authentication data, including MFA TOTP secrets, recovery codes, and OAuth access tokens. An attacker who knows a user's password can extract the MFA secret to generate valid MFA codes, defeating multi-factor authentication protection.
Patches
The verify password endpoint now sanitizes authentication data through auth adapter hooks before returning the response, consistent with login and user retrieval endpoints.
Workarounds
There is no known workaround.
NVD description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.63 and 9.7.0-alpha.7, the verify password endpoint returns unsanitized authentication data, including MFA TOTP secrets, recovery codes, and OAuth access tokens. An attacker who knows a user's password can extract the MFA secret to generate valid MFA codes, defeating multi-factor authentication protection. This issue has been patched in versions 8.6.63 and 9.7.0-alpha.7.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free