En resumen
- CVE-2026-35648 es una vulnerabilidad MEDIO (CVSS 5.9) que afecta a openclaw (openclaw), openclaw.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.22%, mayor que el 12.3% de las vulnerabilidades.
- Solución: actualizar a 2026.3.22 o posterior.
| Package | Affected versions | Patched versions |
|---|
| openclaw | < 2026.3.22
| 2026.3.22
|
| openclaw npm | < 2026.3.22
| 2026.3.22
|
Description
Summary
Queued node actions were not revalidated against current command policy when later delivered, so stale allowlists or declarations could survive policy tightening.
Affected Packages / Versions
- Package:
openclaw (npm)
- Affected: < 2026.3.22
- Fixed: >= 2026.3.22
- Latest released tag checked:
v2026.3.23-2 (630f1479c44f78484dfa21bb407cbe6f171dac87)
- Latest published npm version checked:
2026.3.23-2
Fix Commit(s)
ec2c6d83b9f5f91d6d9094842e0f19b88e63e3e2
Release Status
The fix shipped in v2026.3.22 and remains present in v2026.3.23 and v2026.3.23-2.
Code-Level Confirmation
- src/gateway/server-methods/nodes.ts now revalidates queued actions against the current allowlist and declared command set at delivery time.
- src/gateway/server-methods/nodes.invoke-wake.test.ts includes the shipped stale-queue regression coverage.
OpenClaw thanks @zpbrent for reporting.
NVD description
OpenClaw before 2026.3.22 contains a policy bypass vulnerability where queued node actions are not revalidated against current command policy when delivered. Attackers can exploit stale allowlists or declarations that survive policy tightening to execute unauthorized commands.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free