En resumen
- CVE-2026-40074 es una vulnerabilidad ALTO (CVSS 7.5) que afecta a kit (svelte), @sveltejs/kit.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.37%, mayor que el 30.4% de las vulnerabilidades.
- Solución: actualizar a 2.57.1 o posterior.
| Package | Affected versions | Patched versions |
|---|
| kit | < 2.57.1
| 2.57.1
|
| @sveltejs/kit npm | < 2.57.1
| 2.57.1
|
Description
redirect, when called from inside the handle server hook with a location parameter containing characters that are invalid in a HTTP header, will cause an unhandled TypeError. This could result in DoS on some platforms, especially if the location passed to redirect contains unsanitized user input.
NVD description
SvelteKit is a framework for rapidly developing robust, performant web applications using Svelte. Prior to 2.57.1, redirect, when called from inside the handle server hook with a location parameter containing characters that are invalid in a HTTP header, will cause an unhandled TypeError. This could result in DoS on some platforms, especially if the location passed to redirect contains unsanitized user input. This vulnerability is fixed in 2.57.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free