En resumen
- CVE-2026-40091 es una vulnerabilidad MEDIO (CVSS 4.4) que afecta a github.com/authzed/spicedb, spicedb (authzed).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.17%, mayor que el 5.9% de las vulnerabilidades.
- Solución: actualizar a 1.51.1 o posterior.
Description
Impact
When SpiceDB starts with log level info, the startup "configuration" log will include the full datastore DSN, including the plaintext password, inside DatastoreConfig.URI.
Patches
v1.51.1
Workarounds
Change the log level to warn or error.
NVD description
SpiceDB is an open source database system for creating and managing security-critical application permissions. In versions 1.49.0 through 1.51.0, when SpiceDB starts with log level info, the startup "configuration" log will include the full datastore DSN, including the plaintext password, inside DatastoreConfig.URI. This issue has been fixed in version 1.51.1. If users are unable to immediately upgrade, they can work around this issue by changing the log level to warn or error.
Más vulnerabilidades de github.com/authzed/spicedb
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free