En resumen
- CVE-2026-40879 es una vulnerabilidad ALTO (CVSS 7.5) que afecta a nest (nestjs), @nestjs/microservices.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.33%, mayor que el 26.1% de las vulnerabilidades.
- Solución: actualizar a 11.1.19 o posterior.
Description
Impact
Attacker sends many small, valid JSON messages in one TCP frame
→ handleData() recurses once per message; buffer shrinks each call
→ maxBufferSize is never reached; call stack overflows instead
→ A ~47 KB payload is sufficient to trigger RangeError
Patches
Fixed in @nestjs/[email protected]
References
Discovered by https://github.com/hwpark6804-gif
NVD description
Nest is a framework for building scalable Node.js server-side applications. Prior to 11.1.19, when an attacker sends many small, valid JSON messages in one TCP frame, handleData() recurses once per message; the buffer shrinks each call. maxBufferSize is never reached; call stack overflows instead. A ~47 KB payload is sufficient to trigger RangeError. This vulnerability is fixed in 11.1.19.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free