| Package | Affected versions | Patched versions |
|---|---|---|
| apache-airflow-providers-keycloak | ≥ 0.0.1, < 0.7.0 | 0.7.0 |
| apache-airflow-providers-keycloak | ≥ 0.0.1, < 0.7.0 | 0.7.0 |
The Keycloak authentication manager in apache-airflow-providers-keycloak did not generate or validate the OAuth 2.0 state parameter on the login / login-callback flow, and did not use PKCE. An attacker with a Keycloak account in the same realm could deliver a crafted callback URL to a victim's browser and cause the victim to be logged into the attacker's Airflow session (login-CSRF / session fixation), where any credentials the victim subsequently stored in Airflow Connections would be harvestable by the attacker. Users are advised to upgrade apache-airflow-providers-keycloak to 0.7.0 or later.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free