En resumen
- CVE-2026-42308 es una vulnerabilidad MEDIO (CVSS 5.5) que afecta a pillow, pillow (python).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.11%, mayor que el 1.4% de las vulnerabilidades.
- Solución: actualizar a 12.2.0 o posterior.
| Package | Affected versions | Patched versions |
|---|
| pillow PyPI | < 12.2.0
| 12.2.0
|
| pillow | < 12.2.0
| 12.2.0
|
Description
If a font advances for each glyph by an exceeding large amount, when Pillow keeps track of the current position, it may lead to an integer overflow. This has been fixed.
NVD description
Pillow is a Python imaging library. Prior to version 12.2.0, if a font advances for each glyph by an exceeding large amount, when Pillow keeps track of the current position, it may lead to an integer overflow. This issue has been patched in version 12.2.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free