En resumen
- CVE-2026-42570 es una vulnerabilidad ALTO (CVSS 7.5) que afecta a devalue (svelte), devalue.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.40%, mayor que el 33.9% de las vulnerabilidades.
- Solución: actualizar a 5.8.1 o posterior.
| Package | Affected versions | Patched versions |
|---|
| devalue | ≥ 5.6.3, < 5.8.1
| 5.8.1
|
| devalue npm | ≥ 5.6.3, < 5.8.1
| 5.8.1
|
Description
devalue.parse could, due to quirks in some JavaScript engines, be convinced to allocate much more memory than was needed when deserializing sparse arrays, leading to excessive memory consumption.
NVD description
Svelte devalue is a JavaScript library that serializes values into strings when JSON.stringify isn't sufficient for the job. From version 5.6.3 to before version 5.8.1, devalue.parse could, due to quirks in some JavaScript engines, be convinced to allocate much more memory than was needed when deserializing sparse arrays, leading to excessive memory consumption. This issue has been patched in version 5.8.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free