En resumen
- CVE-2026-45787 es una vulnerabilidad CRÍTICO (CVSS 9.1) que afecta a electerm (electerm project), electerm.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.10%, mayor que el 1.1% de las vulnerabilidades.
- Solución: actualizar a 3.9.5 o posterior.
| Package | Affected versions | Patched versions |
|---|
| electerm | < 3.9.5
| 3.9.5
|
| electerm npm | < 3.9.5
| 3.9.5
|
Description
Impact
Insecure sync encryption: deterministic AES-192-CBC with a fixed zero IV, constant KDF salt, and no MAC leads to confidentiality and integrity failures for synced bookmark/profile data. Attackers can crack common passwords across installs and perform undetected ciphertext bit-flips to alter config/bookmarks.
Patches
Workarounds
References
NVD description
electerm is an open-sourced terminal/ssh/sftp/telnet/serialport/RDP/VNC/Spice/ftp client. Prior to 3.9.5, deterministic AES-192-CBC with a fixed zero IV, constant KDF salt, and no MAC leads to confidentiality and integrity failures for synced bookmark/profile data. Attackers can crack common passwords across installs and perform undetected ciphertext bit-flips to alter config/bookmarks. This vulnerability is fixed in 3.9.5.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free