En resumen
- CVE-2026-48155 es una vulnerabilidad MEDIO (CVSS 5.5) que afecta a pypdf, pypdf (pypdf project).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.13%, mayor que el 2.4% de las vulnerabilidades.
- Solución: actualizar a 6.12.0 o posterior.
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | < 6.12.0
| 6.12.0
|
| pypdf | < 6.12.0
| 6.12.0
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to large memory usage. This requires extracting text in layout mode with large character offsets.
Patches
This has been fixed in pypdf==6.12.0.
Workarounds
If developers are unable to immediately upgrade, they should consider applying the changes from PR #3790.
NVD description
pypdf is a free and open-source pure-python PDF library. Prior to 6.12.0, an attacker who uses this vulnerability can craft a PDF which leads to large memory usage. This requires extracting text in layout mode with large character offsets. This vulnerability is fixed in 6.12.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free