En resumen
- CVE-2026-48156 es una vulnerabilidad BAJO (CVSS 3.3) que afecta a pypdf, pypdf (pypdf project).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.12%, mayor que el 2.1% de las vulnerabilidades.
- Solución: actualizar a 6.12.0 o posterior.
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | < 6.12.0
| 6.12.0
|
| pypdf | < 6.12.0
| 6.12.0
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to long runtimes. This requires cross-reference streams with /W [0 0 0] values and large /Size values.
Patches
This has been fixed in pypdf==6.12.0.
Workarounds
If developers are unable to upgrade their apps immediately, they should consider applying the changes from PR #3791.
NVD description
pypdf is a free and open-source pure-python PDF library. Prior to 6.12.0, an attacker who uses this vulnerability can craft a PDF which leads to long runtimes. This requires cross-reference streams with /W [0 0 0] values and large /Size values. This vulnerability is fixed in 6.12.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free