En resumen
- CVE-2026-48735 es una vulnerabilidad MEDIO (CVSS 5.5) que afecta a pypdf, pypdf (pypdf project).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.13%, mayor que el 2.5% de las vulnerabilidades.
- Solución: actualizar a 6.12.1 o posterior.
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | < 6.12.1
| 6.12.1
|
| pypdf | < 6.12.1
| 6.12.1
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to large memory usage. This requires parsing large XMP metadata, possibly with lots of unnecessary elements.
Patches
This has been fixed in pypdf==6.12.1.
Workarounds
If you cannot upgrade yet, consider applying the changes from PR #3796.
NVD description
pypdf is a free and open-source pure-python PDF library. Prior to 6.12.1, an attacker who uses this vulnerability can craft a PDF which leads to large memory usage. This requires parsing large XMP metadata, possibly with lots of unnecessary elements. This vulnerability is fixed in 6.12.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free