En resumen
- CVE-2026-49287 es una vulnerabilidad ALTO (CVSS 7.4) que afecta a statamic/cms.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.46%, mayor que el 39.7% de las vulnerabilidades.
- Solución: actualizar a 6.20.0, 5.73.23 o posterior.
| Package | Affected versions | Patched versions |
|---|
| statamic/cms Packagist | ≥ 6.0.0, < 6.20.0< 5.73.23
| 6.20.05.73.23
|
Description
Impact
The fix for GHSA-4jjr-vmv7-wh4w was incomplete. It addressed the issue in the query builder, but the same protection was not applied to in-memory collection sorting. Manipulating sort parameters could result in the loss of content and assets.
This requires a front-end template that passes request input into a tag's sort parameter. It is not exploitable by default — a template would need to be explicitly set up to sort by a visitor-controlled value.
Patches
This has been fixed in 5.73.23 and 6.20.0.
NVD description
Statamic is a Laravel and Git powered content management system (CMS). Prior to 5.73.23 and 6.20.0, the fix for CVE-2026-41175 was incomplete. It addressed the issue in the query builder, but the same protection was not applied to in-memory collection sorting. Manipulating sort parameters could result in the loss of content and assets. This requires a front-end template that passes request input into a tag's sort parameter. It is not exploitable by default — a template would need to be explicitly set up to sort by a visitor-controlled value. This has been fixed in 5.73.23 and 6.20.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free