En resumen
- CVE-2026-5038 es una vulnerabilidad ALTO (CVSS 7.5) que afecta a multer (expressjs), multer.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.37%, mayor que el 30.6% de las vulnerabilidades.
- Solución: actualizar a 2.2.0, 3.0.0-alpha.2 o posterior.
| Package | Affected versions | Patched versions |
|---|
| multer | = 3.0.0≥ 2.0.0, < 2.2.0
| 2.2.0
|
| multer npm | ≥ 2.0.0-alpha.1, < 2.2.0≥ 3.0.0-alpha.1, < 3.0.0-alpha.2
| 2.2.03.0.0-alpha.2
|
Description
Impact
A vulnerability in Multer allows an attacker to trigger a Denial of Service (DoS) by aborting or sending malformed multipart uploads, causing orphaned partial files to accumulate on disk when using diskStorage.
Patches
Users should upgrade to 2.2.0, 3.0.0-alpha.2 or higher
Workarounds
None
NVD description
Impact: multer versions 2.0.0-alpha.1 through 2.1.1 and 3.0.0-alpha.1 are vulnerable to a Denial of Service when using diskStorage. Aborted or malformed multipart uploads leave orphaned partial files on disk because the Readable.pipe() call does not propagate the stream destroy signal to
the underlying fs.WriteStream. An attacker can exhaust disk space by triggering many aborted uploads, with no application bug required.
Patches: Users should upgrade to multer 2.2.0 (2.x line) or 3.0.0-alpha.2 (3.x prerelease). Both versions track in-flight write streams and clean them up on the abort path.
Workarounds: None.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free