En resumen
- CVE-2026-52857 es una vulnerabilidad MEDIO (CVSS 5.5) que afecta a github.com/pterodactyl/wings.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.16%, mayor que el 5.2% de las vulnerabilidades.
- Solución: actualizar a 1.13.0 o posterior.
Description
Summary
Config file parsers, json, yaml, xml etc in parser.go have no file size limit/checks, allowing for a giant config file to potentially OOM the wings process.
Impact
All wings users who have an egg with a non-file parser configuration file setting.
NVD description
Wings is the server control plane for Pterodactyl, a free, open-source game server management panel. Prior to 1.13.0, unbounded json, yaml, and xml configuration-file parsers in parser.go can process an oversized non-file parser configuration file and exhaust Wings process memory. This issue is fixed in version 1.13.0.
Más vulnerabilidades de github.com/pterodactyl/wings
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free