En resumen
- CVE-2026-53718 es una vulnerabilidad MEDIO (CVSS 6.4) que afecta a github.com/envoyproxy/gateway.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.41%, mayor que el 35.6% de las vulnerabilidades.
- Solución: actualizar a 1.8.1, 1.7.4 o posterior.
Description
Impact
Envoy Gateway accepts extension-managed custom backendRefs from an HTTPRoute to a backend resource in another namespace without requiring a matching Gateway API ReferenceGrant in the target namespace. This breaks the Gateway API cross-namespace consent model: the namespace that owns the referenced backend resource does not need to opt in with a ReferenceGrant before another namespace’s HTTPRoute can use that resource.
Patches
1.7.4
1.8.1
NVD description
Envoy Gateway is an open source project for managing Envoy Proxy as a standalone or Kubernetes-based application gateway. Prior to 1.7.4 and 1.8.1, an HTTPRoute can use an extension-managed custom backendRef to reference a backend resource in another namespace without a matching Gateway API ReferenceGrant in the target namespace. The custom-backend branch in internal/gatewayapi/route.go omits validateBackendNamespace, allowing the route-owning namespace to bind to and use the resource without the backend namespace owner's consent and violating the Gateway API cross-namespace authorization model. This issue is fixed in versions 1.7.4 and 1.8.1.
Más vulnerabilidades de github.com/envoyproxy/gateway
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free