En resumen
- CVE-2026-54306 es una vulnerabilidad MEDIO (CVSS 6.4) que afecta a n8n (n8n), n8n.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.28%, mayor que el 20.5% de las vulnerabilidades.
- Solución: actualizar a 2.26.2, 2.25.7 o posterior.
| Package | Affected versions | Patched versions |
|---|
| n8n | ≥ 2.26.0, < 2.26.2< 2.25.7
| 2.26.22.25.7
|
| n8n npm | ≥ 2.26.0, < 2.26.2< 2.25.7
| 2.26.22.25.7
|
Description
Impact
A prototype pollution vulnerability allowed a crafted public webhook payload to inject attacker-controlled fields into workflow data during internal object copying. These fields could be surfaced and consumed as normal values by downstream built-in nodes.
Where a workflow combines a public webhook with action nodes that consume the resulting fields, an attacker could cause the workflow to act as a confused deputy — targeting unintended records or issuing outbound requests using the workflow owner's configured credentials.
Patches
The issue has been fixed in n8n versions 2.25.7, and 2.26.2. Users should upgrade to one of these versions or later to remediate the vulnerability.
Workarounds
If upgrading is not immediately possible, administrators should consider the following temporary mitigations:
- Avoid exposing public (unauthenticated) webhook workflows that pass incoming data through transform nodes into action nodes with sensitive credentials or database operations.
- Limit workflow creation and editing permissions to fully trusted users only.
These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.
NVD description
n8n is an open source workflow automation platform. Prior to 2.25.7 and 2.26.2, a prototype pollution vulnerability allowed a crafted public webhook payload to inject attacker-controlled fields into workflow data during internal object copying. These fields could be surfaced and consumed as normal values by downstream built-in nodes. Where a workflow combines a public webhook with action nodes that consume the resulting fields, an attacker could cause the workflow to act as a confused deputy — targeting unintended records or issuing outbound requests using the workflow owner's configured credentials. This vulnerability is fixed in 2.25.7 and 2.26.2.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free