En resumen
- CVE-2026-54308 es una vulnerabilidad ALTO (CVSS 7.2) que afecta a n8n (n8n), n8n.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.30%, mayor que el 22.6% de las vulnerabilidades.
- Solución: actualizar a 2.26.2, 2.25.7 o posterior.
| Package | Affected versions | Patched versions |
|---|
| n8n | ≥ 2.26.0, < 2.26.2< 2.25.7
| 2.26.22.25.7
|
| n8n npm | ≥ 2.26.0, < 2.26.2< 2.25.7
| 2.26.22.25.7
|
Description
Impact
The MicrosoftAgent365Trigger and StripeTrigger node did not validate that inbound requests. As a result, an unauthenticated attacker who knows the webhook URL could submit a forged payload and cause the workflow to execute with attacker-controlled data.
Patches
The issue has been fixed in n8n versions 2.25.7, and 2.26.2. Users should upgrade to one of these versions or later to remediate the vulnerability.
Workarounds
If upgrading is not immediately possible, administrators should consider the following temporary mitigations:
- Deactivate any workflows using the Microsoft Agent 365 Trigger node or Stripe Trigger node until the instance can be upgraded.
- Restrict network access to the n8n webhook endpoint to trusted sources only.
These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.
NVD description
n8n is an open source workflow automation platform. Prior to 2.25.7 and 2.26.2, the MicrosoftAgent365Trigger and StripeTrigger node did not validate that inbound requests. As a result, an unauthenticated attacker who knows the webhook URL could submit a forged payload and cause the workflow to execute with attacker-controlled data. This vulnerability is fixed in 2.25.7 and 2.26.2.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free