En resumen
- CVE-2026-54530 es una vulnerabilidad MEDIO (CVSS 5.5) que afecta a pypdf, pypdf (pypdf project).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.17%, mayor que el 6.9% de las vulnerabilidades.
- Solución: actualizar a 6.13.0 o posterior.
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | < 6.13.0
| 6.13.0
|
| pypdf | < 6.13.0
| 6.13.0
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to an infinite loop. This requires extracting the text in layout mode.
Patches
This has been fixed in pypdf==6.13.0.
Workarounds
If you cannot upgrade yet, consider applying the changes from PR #3830.
NVD description
pypdf is a free and open-source pure-python PDF library. Prior to 6.13.0, an attacker who uses this vulnerability can craft a PDF which leads to an infinite loop. This requires extracting the text in layout mode. This vulnerability is fixed in 6.13.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free