En resumen
- CVE-2026-54651 es una vulnerabilidad MEDIO (CVSS 5.5) que afecta a pypdf, pypdf (py-pdf).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.16%, mayor que el 4.9% de las vulnerabilidades.
- Solución: actualizar a 6.13.1 o posterior.
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | < 6.13.1
| 6.13.1
|
| pypdf | < 6.13.1
| 6.13.1
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to an infinite loop. This requires merging a file with threads/articles into a writer.
Patches
This has been fixed in pypdf==6.13.1.
Workarounds
If users cannot upgrade yet, consider applying the changes from PR #3839.
NVD description
pypdf is a free and open-source pure-python PDF library. Prior to 6.13.1, an attacker who uses this vulnerability can craft a PDF which leads to an infinite loop. This requires merging a file with threads/articles into a writer. This vulnerability is fixed in 6.13.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free