En resumen
- CVE-2026-55170 es una vulnerabilidad MEDIO (CVSS 5.4) que afecta a github.com/openfga/openfga, helm charts (openfga), openfga (openfga).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.34%, mayor que el 27.4% de las vulnerabilidades.
- Solución: actualizar a 1.18.0, 0.3.9 o posterior.
Description
Description
In OpenFGA, when MySQL is being used as the datastore, two distinct check requests can return the same response.
Preconditions
This applies if the following preconditions are met:
- You run OpenFGA with MySQL as the datastore
- Your authorization decisions rely on case-sensitive user strings.
Fix
Upgrade to OpenFGA 1.18.0 or greater.
Acknowledgements
OpenFGA would like to thank @sahajamoth for the detailed report.
NVD description
OpenFGA is an authorization/permission engine built for developers. Prior to 1.18.0, when MySQL is being used as the datastore and authorization decisions rely on case-sensitive user strings, the tuple, changelog, and authorization_model identifier columns can compare case-distinct values such as user:Alice and user:alice as equivalent, causing two distinct check requests to return the same response. This issue is fixed in 1.18.0.
Más vulnerabilidades de github.com/openfga/openfga
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free