En resumen
- CVE-2026-55211 es una vulnerabilidad CRÍTICO (CVSS 9.8) que afecta a surfio.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.74%, mayor que el 54.8% de las vulnerabilidades.
- Solución: actualizar a 0.0.19 o posterior.
| Package | Affected versions | Patched versions |
|---|
| surfio PyPI | < 0.0.19
| 0.0.19
|
Description
Impact
Prior to version 0.0.19, surfio would not correctly validate size fields in irap files, leading to a buffer overflow . The severity rating assumes that surfio is used to parse untrused files in a networking context such as a web service.
Patches
The bug has been patched in version 0.0.19
NVD description
Surfio is a library for reading and writing surface files. Prior to 0.0.19, surfio does not correctly validate size fields in IRAP files, leading to a buffer overflow when untrusted files are parsed. The severity assumes surfio is used to parse untrusted files in a networking context such as a web service. This issue is fixed in version 0.0.19.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free