| Package | Affected versions | Patched versions |
|---|---|---|
| metabase | ≥ 1.55.0, < 1.58.15.1≥ 1.59.0, < 1.59.12≥ 1.60.0, < 1.60.6.3≥ 1.61.0, < 1.61.2 | 1.58.15.11.59.121.60.6.31.61.2 |
Metabase is an open-source business intelligence and embedded analytics tool. From 1.55.0 until 1.58.15.1, 1.59.12, 1.60.6.3, and 1.61.2, Metabase did not validate unsafe H2 connection properties on one database-creation code path, allowing an authenticated administrator to register a crafted H2 database connection and execute arbitrary Java code on the Metabase server. This issue is fixed in versions 1.58.15.1, 1.59.12, 1.60.6.3, and 1.61.2.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free