En resumen
- CVE-2026-59938 es una vulnerabilidad MEDIO (CVSS 5.3) que afecta a pypdf, pypdf (pypdf project).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.52%, mayor que el 43.9% de las vulnerabilidades.
- Solución: actualizar a 6.14.0 o posterior.
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | < 6.14.0
| 6.14.0
|
| pypdf | < 6.14.0
| 6.14.0
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to large memory usage. This requires loading images where the declared size values are much too large compared to the actual data.
Patches
This has been fixed in pypdf==6.14.0.
Workarounds
If you cannot upgrade yet, consider applying the changes from PR #3888.
NVD description
pypdf is a free and open-source pure-python PDF library. Prior to 6.14.0, an attacker can craft a PDF with declared image size values that are much too large compared to the actual data, causing large memory usage in pypdf image parsing. This issue is fixed in version 6.14.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free