En resumen
- CVE-2026-61845 es una vulnerabilidad ALTO (CVSS 8.9) que afecta a crass.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.39%, mayor que el 33.0% de las vulnerabilidades.
- Solución: actualizar a 1.0.7 o posterior.
| Package | Affected versions | Patched versions |
|---|
| crass RubyGems | < 1.0.7
| 1.0.7
|
Description
Impact
Crass converts CSS scientific notation number values with unbounded exponentiation before it clamps the result to Float::MAX. Applications that use Crass to parse attacker-controlled CSS strings can be forced to spend disproportionate CPU and memory parsing a tiny input, possibly resulting in a crash.
Patches
This is fixed in Crass 1.0.7.
Related
NVD description
Crass is a Ruby CSS parser that's fully compliant with the CSS Syntax Level 3 specification. Prior to 1.0.7, Crass converts `CSS scientific notation` number values with unbounded exponentiation before clamping the result to `Float::MAX`. Applications that use Crass to parse attacker-controlled CSS strings can be forced to spend disproportionate CPU and memory parsing a tiny input, potentially resulting in a crash. This issue is fixed in version 1.0.7.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free