En resumen
- CVE-2026-63131 es una vulnerabilidad MEDIO (CVSS 6.0) que afecta a github.com/openbao/openbao.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.48%, mayor que el 41.7% de las vulnerabilidades.
- Solución: actualizar a 0.0.0-20260713133043-f58d848c139e o posterior.
| Package | Affected versions | Patched versions |
|---|
| github.com/openbao/openbao Go | ≥ 0.1.0, ≤ 1.1.5≥ 0.1.0< 0.0.0-20260713133043-f58d848c139e
| 0.0.0-20260713133043-f58d848c139e
|
Description
Impact
When a policy operator has written capabilities = ["deny"] on a path with a trailing wildcard but allowed a broader list operation (e.g., a deny on secrets/metadata/restricted/* but allowed list on secrets/metadata/*), OpenBao would incorrectly allow the operation. This did not impact other operation types.
Patches
This has been patched in OpenBao v2.6.0.
NVD description
OpenBao is an open source identity-based secrets management system. Prior to 2.6.0, OpenBao's vault/policy/acl.go could evaluate a broader wildcard ACL grant before more-specific trailing-wildcard ACL paths with capabilities = ["deny"] for a LIST operation. When a parent path permitted LIST and a child path was denied, the trailing-slash lookup could therefore allow listing the denied path. Other operation types are outside the repository advisory's affected scope. This issue is fixed in version 2.6.0.
Más vulnerabilidades de github.com/openbao/openbao
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free