| Package | Affected versions | Patched versions |
|---|---|---|
| github.com/hashicorp/boundary | ≥ 0.20.0, < 0.20.3≥ 0.21.0, < 0.21.3< 0.19.5 | 0.20.30.21.30.19.5 |
Boundary Community Edition and Boundary Enterprise ("Boundary") workers are vulnerable to a denial-of-service condition during node enrollment TLS handshakes. An attacker with network access to the worker authentication listener may open a connection and delay or withhold the client certificate during the TLS handshake, causing worker connection handling to block. This may prevent legitimate worker connections from being accepted or routed. This vulnerability, CVE-2026-7776, is fixed in Boundary 0.21.3, 0.20.3, 0.19.5.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free