En resumen
- CVE-2026-81176 es una vulnerabilidad MEDIO (CVSS 5.3) que afecta a devalue.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.51%, mayor que el 43.3% de las vulnerabilidades.
- Solución: actualizar a 5.9.2 o posterior.
| Package | Affected versions | Patched versions |
|---|
| devalue npm | < 5.9.2
| 5.9.2
|
Description
Impact
devalue.parse prior to version 5.9.2 fails to reject out-of-bounds indices. Specially-crafted payloads can exploit this to cause devalue to alternate between different array representations, resulting in work that is quadratic with payload size.
Applications are potentially affected if they call devalue.parse with untrusted data.
Patches
The bug is fixed in [email protected].
NVD description
Svelte devalue is a JavaScript library that serializes values into strings when JSON.stringify isn't sufficient for the job. Prior to 5.9.2, devalue.parse does not reject out-of-bounds indices that are greater than or equal to values.length in src/parse.js. A specially crafted untrusted payload can make the parser alternate between array representations, producing quadratic work as the payload grows and causing denial of service in applications that parse untrusted devalue data. This issue is fixed in version 5.9.2.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free