En resumen
- CVE-2026-82858 es una vulnerabilidad CRÍTICO (CVSS 9.8) que afecta a @hulumi/drift.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.29%, mayor que el 21.0% de las vulnerabilidades.
- Solución: actualizar a 1.3.2 o posterior.
| Package | Affected versions | Patched versions |
|---|
| @hulumi/drift npm | < 1.3.2
| 1.3.2
|
Description
Impact: @hulumi/drift versions before 1.3.2 could accept externally supplied execute plans without sufficient provenance checks, allowing unsafe reconciliation input to be treated as trusted.
Patched in 1.3.2: execute-plan handling now validates provenance and rejects untrusted plans, with regression coverage.
Remediation: upgrade @hulumi/drift to 1.3.2 or later.
NVD description
@hulumi/drift versions before 1.3.2 accept externally supplied execute plans without sufficient provenance validation, allowing untrusted reconciliation input to be treated as trusted. Attackers can supply malicious execute plans that bypass security checks to perform unsafe reconciliation operations.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free