En resumen
- CVE-2026-86074 es una vulnerabilidad ALTO (CVSS 7.1) que afecta a n8n (n8n), n8n.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.38%, mayor que el 31.6% de las vulnerabilidades.
- Solución: actualizar a 2.38.2, 2.37.7 o posterior.
| Package | Affected versions | Patched versions |
|---|
| n8n | ≥ 2.38.0, < 2.38.2< 2.37.7
| 2.38.22.37.7
|
| n8n npm | ≥ 2.38.0, < 2.38.2< 2.37.7
| 2.38.22.37.7
|
Description
Impact
Instance AI credential setup accepted a credential test/verification URL without checking it matched the workflow node's origin. Exfiltration required the user to actively inject an attacker-controlled URL into the setup flow. The patch derives the credential destination from the node's own URL and confines authenticated requests, redirects and probes to that origin.
Patches
The issue has been fixed in n8n versions 2.38.2 and 2.37.7. Users should upgrade to one of these versions or later to remediate the vulnerability.
Workarounds
If upgrading is not immediately possible, administrators should consider the following temporary mitigations:
- Disable the Instance AI module by removing
instance-ai from the N8N_ENABLED_MODULES environment variable if it is not required.
- Restrict n8n instance access to fully trusted users only.
- Rotate any third-party API credentials that were set up using the Instance AI credential-setup flow on affected versions.
These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.
NVD description
n8n is an open source workflow automation platform. Prior to 2.37.7 and 2.38.2, the Instance AI credential setup flow accepted a credential test or verification URL without checking that it matched the workflow node's origin. Attacker-controlled fetched content could influence that URL after a user injected it into the setup flow, causing authenticated requests, redirects, or probes to reach another origin. The affected logic includes packages/@n8n/instance-ai/src/tools/workflows/credential-utils.ts and the extractServiceOrigin origin derivation. This issue is fixed in versions 2.37.7 and 2.38.2.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free