| Package | Affected versions | Patched versions |
|---|---|---|
| mariadb | = 13.0.1≥ 10.11.1, < 10.11.19≥ 10.6.1, < 10.6.28≥ 11.4.1, < 11.4.13≥ 11.8.1, < 11.8.9≥ 12.3.1, < 12.3.3 | 10.11.1910.6.2811.4.1311.8.912.3.3 |
MariaDB server is a community developed fork of MySQL server. From 10.6.1 until 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2, the GRANT PROXY statement treats an IDENTIFIED clause with an empty password as though authentication were not specified, causing it to check the wrong grantor privileges. A low-privileged attacker who can name another account can exploit this authorization error to set that account's password. This issue is fixed in versions 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free