En bref
- CVE-2014-3741 est une vulnérabilité CRITIQUE (CVSS 9.8) touchant node-printer (node-printer project), printer.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 3.8%, plus élevée que 90.0% des vulnérabilités.
- Correctif : mettre à jour vers 0.0.2 ou plus récent.
Description
Versions 0.0.1 and earlier of printer are affected by a command injection vulnerability resulting from a failure to sanitize command arguments properly in the printDirect() function.
Recommendation
Update to version 0.0.2 or later.
NVD description
The printDirect function in lib/printer.js in the node-printer module 0.0.1 and earlier for Node.js allows remote attackers to execute arbitrary commands via unspecified characters in the lpr command.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free