En bref
- CVE-2014-3743 est une vulnérabilité MOYENNE (CVSS 6.1) touchant marked (marked project), marked.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 1.7%, plus élevée que 77.5% des vulnérabilités.
- Correctif : mettre à jour vers 0.3.1 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| marked | < 0.3.1
| 0.3.1
|
| marked npm | < 0.3.1
| 0.3.1
|
Description
Versions 0.3.0 and earlier of marked are affected by two cross-site scripting vulnerabilities, even when sanitize: true is set.
The attack vectors for this vulnerability are GFM Codeblocks and JavaScript URLs.
Recommendation
Upgrade to version 0.3.1 or later.
NVD description
Multiple cross-site scripting (XSS) vulnerabilities in the Marked module before 0.3.1 for Node.js allow remote attackers to inject arbitrary web script or HTML via vectors related to (1) gfm codeblocks (language) or (2) javascript url's.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free