En bref
- CVE-2014-7192 est une vulnérabilité CRITIQUE (CVSS 10.0) touchant node.js (joyent), syntax-error.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 13.0%, plus élevée que 96.3% des vulnérabilités.
- Correctif : mettre à jour vers 1.1.1 ou plus récent.
Description
Versions of syntax-error prior to 1.1.1 are affected by a cross-site scripting vulnerability which may allow a malicious file to execute code when browserified.
Recommendation
Update to version 1.1.1 or later.
NVD description
Eval injection vulnerability in index.js in the syntax-error package before 1.1.1 for Node.js 0.10.x, as used in IBM Rational Application Developer and other products, allows remote attackers to execute arbitrary code via a crafted file.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free