En bref
- CVE-2015-1369 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant sequelize (sequelize project), sequelize.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 2.1%, plus élevée que 81.8% des vulnérabilités.
- Correctif : mettre à jour vers 2.0.0-rc8 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| sequelize | ≤ 2.0.0
| No fix yet |
| sequelize npm | < 2.0.0-rc8
| 2.0.0-rc8
|
Description
Versions 2.0.0-rc-7 and earlier of sequelize are affected by a SQL injection vulnerability when user input is passed into the order parameter.
Proof of Concept
Test.findAndCountAll({
where: { id :1 },
order : [['id', 'UNTRUSTED USER INPUT']]
})
Recommendation
Update to version 2.0.0-rc8 or later
NVD description
SQL injection vulnerability in Sequelize before 2.0.0-rc7 for Node.js allows remote attackers to execute arbitrary SQL commands via the order parameter.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free