En bref
- CVE-2015-5654 est une vulnérabilité MOYENNE (CVSS 4.3) touchant dojo (dojotoolkit), dojo.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 2.2%, plus élevée que 82.7% des vulnérabilités.
- Correctif : mettre à jour vers 1.9.1 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| dojo | ≤ 1.1.1
| No fix yet |
| dojo npm | < 1.9.1
| 1.9.1
|
Description
Versions of dojo prior to 1.2.0 are vulnerable to Cross-Site Scripting (XSS). The package fails to sanitize HTML code in user-controlled input, allowing attackers to execute arbitrary JavaScript in the victim's browser.
Recommendation
Upgrade to version 1.2.0 or later.
NVD description
Cross-site scripting (XSS) vulnerability in Dojo Toolkit before 1.2 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free