En bref
- CVE-2015-9244 est une vulnérabilité CRITIQUE (CVSS 9.8) touchant mysql (mysqljs), mysql.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 2.4%, plus élevée que 84.3% des vulnérabilités.
- Correctif : mettre à jour vers 2.0.0-alpha8 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| mysql | = 2.0.0≤ 0.9.6
| No fix yet |
| mysql npm | < 2.0.0-alpha8
| 2.0.0-alpha8
|
Description
Versions of mysql prior to 2.0.0-alpha8 are affected by a SQL Injection vulnerability in the mysql.escape() function, which does not properly escape object keys.
Recommendation
Update to version 2.0.0-alpha8 or later.
NVD description
Keys of objects in mysql node module v2.0.0-alpha7 and earlier are not escaped with `mysql.escape()` which could lead to SQL Injection.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free