En bref
- CVE-2016-10524 est une vulnérabilité ÉLEVÉE (CVSS 8.2) touchant i18n-node-angular (i18n-node-angular project), i18n-node-angular.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.79%, plus élevée que 56.5% des vulnérabilités.
- Correctif : mettre à jour vers 1.4.0 ou plus récent.
Description
Versions of i18n-node-angular prior to 1.4.0 are affected by denial of service and cross-site scripting vulnerabilities. The vulnerabilities exist in a REST endpoint that was created for development purposes, but was not disabled in production in affected versions.
Recommendation
Update to version 1.4.0 or later.
NVD description
i18n-node-angular is a module used to interact between i18n and angular without using additional resources. A REST API endpoint that is used for development in i18n-node-angular before 1.4.0 was not disabled in production environments a malicious user could fill up the server causing a Denial of Service or content injection.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free