En bref
- CVE-2016-10527 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant riot-compiler (riot.js), riot-compiler.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 1.6%, plus élevée que 75.6% des vulnérabilités.
- Correctif : mettre à jour vers 2.3.22 ou plus récent.
Description
Affected versions of riot-compiler are susceptible to a regular expression denial of service vulnerability.
Recommendation
Update to version 2.3.22 or later.
NVD description
The riot-compiler version version 2.3.21 has an issue in a regex (Catastrophic Backtracking) thats make it unusable under certain conditions.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free