En bref
- CVE-2016-10569 est une vulnérabilité ÉLEVÉE (CVSS 8.1) touchant embedza (embedza project), embedza.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 1.7%, plus élevée que 77.7% des vulnérabilités.
- Correctif : mettre à jour vers 1.2.4 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| embedza | < 1.2.4
| 1.2.4
|
| embedza npm | < 1.2.4
| 1.2.4
|
Description
Affected versions of embedza insecurely download an executable over an unencrypted HTTP connection.
In scenarios where an attacker has a privileged network position, it is possible to intercept the response and replace the executable with a malicious one, resulting in code execution on the system running embedza.
Recommendation
Update to version 1.2.4 or later.
NVD description
embedza is a module to create HTML snippets/embeds from URLs using info from oEmbed, Open Graph, meta tags. embedza versions below 1.2.4 download JavaScript resources over HTTP, which leaves it vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested JavaScript file with an attacker controlled JavaScript file if the attacker is on the network or positioned in between the user and the remote server.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free