En bref
- CVE-2016-10694 est une vulnérabilité ÉLEVÉE (CVSS 8.1) touchant alto-saxophone (alto-saxophone project), alto-saxophone.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 2.1%, plus élevée que 81.5% des vulnérabilités.
- Correctif : mettre à jour vers 2.25.1 ou plus récent.
Description
Affected versions of alto-saxophone insecurely download an executable over an unencrypted HTTP connection.
In scenarios where an attacker has a privileged network position, it is possible to intercept the response and replace the executable with a malicious one, resulting in code execution on the system running alto-saxophone.
Recommendation
Update to version 2.25.1 or later.
NVD description
alto-saxophone is a module to install and launch Chromedriver for Mac, Linux or Windows. alto-saxophone versions below 2.25.1 download binary resources over HTTP, which leaves it vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free