En bref
- CVE-2016-20018 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant knex (knexjs), knex.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 1.1%, plus élevée que 66.2% des vulnérabilités.
- Correctif : mettre à jour vers 2.4.0 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| knex | ≤ 2.3.0
| No fix yet |
| knex npm | < 2.4.0
| 2.4.0
|
Description
Knex Knex.js through 2.3.0 has a limited SQL injection vulnerability that can be exploited to ignore the WHERE clause of a SQL query. This vulnerability has been fixed in version 2.4.0.
NVD description
Knex Knex.js through 2.3.0 has a limited SQL injection vulnerability that can be exploited to ignore the WHERE clause of a SQL query.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free