En bref
- CVE-2016-2537 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant is my json valid (is my json valid project), is-my-json-valid.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 1.8%, plus élevée que 79.2% des vulnérabilités.
- Correctif : mettre à jour vers 2.12.4 ou plus récent.
Description
Version of is-my-json-valid before 2.12.4 are vulnerable to regular expression denial of service (ReDoS) via the email validation function.
Recommendation
Update to version 2.12.4 or later.
NVD description
The is-my-json-valid package before 2.12.4 for Node.js has an incorrect exports['utc-millisec'] regular expression, which allows remote attackers to cause a denial of service (blocked event loop) via a crafted string.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free