En bref
- CVE-2017-1001002 est une vulnérabilité CRITIQUE (CVSS 9.8) touchant math.js (mathjs), mathjs.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 2.4%, plus élevée que 83.8% des vulnérabilités.
- Correctif : mettre à jour vers 3.17.0 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| math.js | ≤ 3.17.0
| No fix yet |
| mathjs npm | < 3.17.0
| 3.17.0
|
Description
math.js before 3.17.0 had an arbitrary code execution in the JavaScript engine. Creating a typed function with JavaScript code in the name could result arbitrary execution.
Recommendation
Update to version 3.17.0 or later.
NVD description
math.js before 3.17.0 had an arbitrary code execution in the JavaScript engine. Creating a typed function with JavaScript code in the name could result arbitrary execution.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free