En bref
- CVE-2017-16014 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant http-proxy (http-proxy project), http-proxy.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 1.7%, plus élevée que 76.8% des vulnérabilités.
- Correctif : mettre à jour vers 0.7.0 ou plus récent.
Description
Affected versions of http-proxy are vulnerable to a denial of service attack, wherein an attacker can force an error which will cause the server to crash.
Recommendation
Update to version 0.7.0 or later.
NVD description
Http-proxy is a proxying library. Because of the way errors are handled in versions before 0.7.0, an attacker that forces an error can crash the server, causing a denial of service.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free