En bref
- CVE-2017-16099 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant no-case (no-case project), no-case.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 1.6%, plus élevée que 75.4% des vulnérabilités.
- Correctif : mettre à jour vers 2.3.2 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| no-case | < 2.3.2
| 2.3.2
|
| no-case npm | < 2.3.2
| 2.3.2
|
Description
Affected versions of no-case are vulnerable to a regular expression denial of service when parsing untrusted user input.
Recommendation
Update to version 2.3.2 or later.
NVD description
The no-case module is vulnerable to regular expression denial of service. When malicious untrusted user input is passed into no-case it can block the event loop causing a denial of service condition.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free