En bref
- CVE-2017-16114 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant marked (marked project), marked.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 1.7%, plus élevée que 77.7% des vulnérabilités.
- Correctif : mettre à jour vers 0.3.9 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| marked | < 0.3.9
| 0.3.9
|
| marked npm | < 0.3.9
| 0.3.9
|
Description
Affected versions of marked are vulnerable to a regular expression denial of service.
The amplification in this vulnerability is significant, with 1,000 characters resulting in the event loop being blocked for around 6 seconds.
Recommendation
Update to version 0.3.9 or later.
NVD description
The marked module is vulnerable to a regular expression denial of service. Based on the information published in the public issue, 1k characters can block for around 6 seconds.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free