En bref
- CVE-2017-16118 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant forwarded (forwarded project), forwarded.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 1.9%, plus élevée que 79.3% des vulnérabilités.
- Correctif : mettre à jour vers 0.1.2 ou plus récent.
Description
Affected versions of forwarded are vulnerable to regular expression denial of service when parsing specially crafted user input.
Recommendation
Update to version 0.1.2 or later
NVD description
The forwarded module is used by the Express.js framework to handle the X-Forwarded-For header. It is vulnerable to a regular expression denial of service when it's passed specially crafted input to parse. This causes the event loop to be blocked causing a denial of service condition.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free