En bref
- CVE-2017-16225 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant aegir (aegir project), aegir.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 1.2%, plus élevée que 67.2% des vulnérabilités.
- Correctif : mettre à jour vers 12.0.8 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| aegir | ≥ 12.0.0, ≤ 12.0.7
| No fix yet |
| aegir npm | ≥ 12.0.0, < 12.0.8
| 12.0.8
|
Description
Affected versions of aegir bundle and publish the current users github token to npm when aegir-release is executed.
Recommendation
Update to version 12.0.8 or later.
If you used this module to do a release for your project you should invalidate the GitHub tokens that were leaked.
NVD description
aegir is a module to help automate JavaScript project management. Version 12.0.0 through and including 12.0.7 bundled and published to npm the user (that performed a aegir-release) GitHub token.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free